Engine Management Light Flashing - MeganeSport.net
MeganeSport.net is the premier Megane Forum on the internet. Registered Users do not see the above ads.

Upcoming Events for the Next 14 Day(s)

    + Reply to Thread
    Results 1 to 10 of 10

    Thread: Engine Management Light Flashing

    Share/Bookmark
    1. #1

      Join Date
      Feb 2010
      Location
      Gateshead
      Car
      Ultra Blue 225 RS Stage 1
      Posts
      271

      Default Engine Management Light Flashing

      Hi Everyone

      I tried a search but I am useless at using that function effectively on all forums and this search function seems particularly tough!

      This morning when driving to work after about 30 seconds of driving the engine management light flashed on about 10 times then went off and staid off for the other 20 minutes of driving in.

      I had some Hankooks fitted last night - could it be a tyre pressure issue? Or at least a problem with the fragile tyre pressure sensors??

      Thanks, Duke

    2. #2

      Join Date
      Mar 2010
      Location
      Kandahar Air Base
      Car
      WRX STI - Prodrive
      Posts
      838

      Default

      Missfire, Coil pack or Injector

      Mine did this a couple of times but it hasn't came back since

    3. #3

      Join Date
      Feb 2010
      Location
      Gateshead
      Car
      Ultra Blue 225 RS Stage 1
      Posts
      271

      Default

      ahh thanks mate, I have noticed its a little bit lumpy on idle too which ties up with your description

      is yours running ok now if you have done nothing about it?

    4. #4

      Join Date
      Mar 2010
      Location
      Kandahar Air Base
      Car
      WRX STI - Prodrive
      Posts
      838

      Default

      100% fine, if your concerned book it into Reno for a Diag and they may replace the offending Coil/Injector

    5. #5

      Join Date
      Feb 2010
      Location
      Gateshead
      Car
      Ultra Blue 225 RS Stage 1
      Posts
      271

      Default

      Thanks for the quick replies mate, spot on!

      Sounds as though i may be leaving it if the light stays off seeing as though yours has been fine.

      Just to be a pain - you dont know rough replacement costs for each?

    6. #6

      Join Date
      Mar 2010
      Location
      Kandahar Air Base
      Car
      WRX STI - Prodrive
      Posts
      838

      Default

      Haven't a clue i asked about the Coil and was told they were around £45 as for injectors no idea ! if i were to replace the injectors id uprate them so i could get more out of a Stage 2

    7. #7

      Join Date
      Feb 2010
      Location
      Gateshead
      Car
      Ultra Blue 225 RS Stage 1
      Posts
      271

      Default

      Cheers dude - think i will buy a coil pack and work my way till i find the broken one

    8. #8

      Join Date
      Apr 2007
      Location
      Chelmsford
      Car
      Black R26
      Posts
      7,527

      Default

      If you have a ODB port scanner it should give you a code, then google it and it'll tell if a fault is registered. IF it is a coil it will tell you which piston too

    9. #9

      Join Date
      Feb 2010
      Location
      Gateshead
      Car
      Ultra Blue 225 RS Stage 1
      Posts
      271

      Default

      Ooo that sounds handy wish I had one may have to invest I believe ktec sell them don't they

    10. #10

      Join Date
      Mar 2010
      Location
      Kandahar Air Base
      Car
      WRX STI - Prodrive
      Posts
      838

      Default

      Id invest in an RSTuner from Henk had one for my clio but sold it on when i picked up an Ek9 wished id kept it now though !

    + Reply to Thread

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

       

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts