Squeaking and creaking front end - MeganeSport.net
Google Search
MeganeSport.net is the premier Megane Forum on the internet. Registered Users do not see the above ads.

Upcoming Events for the Next 14 Day(s)

    Results 1 to 2 of 2

    Thread: Squeaking and creaking front end

    Share/Bookmark
    1. #1

      Join Date
      Sep 2015
      Location
      Adelaide
      Car
      Megane RS 225, tuned
      Posts
      2

      Default Squeaking and creaking front end

      Hello all

      New to this forum and have done a lot of research about this but come up trumps!

      I have a 2005 Megane Mk2 (RS225 in Australia)

      Good condition.

      There is an aggravating and irritating front end squeak and creaking somewhere, on both sides it appears from outside the car.

      It occurs in first gear, accelerating and letting off again, between gear changes and then cruising and accelerating in any gear. It feels like something is loose somewhere.

      I changed the inner tie rods (steering rack ends) with new as they were worn and also the lower and upper control arm bushes but the problem still persists.

      Too me it sounds as though the sway bar bushes are loose or something as the car chassis feels like it is catching up when i do accelerate and the noise occurs. It doesn't appear to occur over general bumps and lumps on the road.

      Very bizarre!

      Please help!

    2. #2

      Join Date
      Sep 2015
      Location
      Adelaide
      Car
      Megane RS 225, tuned
      Posts
      2

      Default

      bump!

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

       

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •