Megane Sport Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi,i have a megane 165 turbo,lovely car 05 plate,just had new back discs and pads done by a non renault garage[renault to expensive],fine,however now and again the abs light and sevice light comes on the dash in the car,amber colour.If i stop the car,re-start it re-sets itself.Been back to the garage and they put a coder in a plug near the gearstick and it said there was no fault.These warning lights dont always come on during a journey,or they dont come when i go over a bump.....HAS anyone got any ideas????? the car has done40 k
 

·
Premium Member
Joined
·
996 Posts
As above, most likely to be the ABS sensor. Get your car looked at by someone with the CLIP code reader & software to see which ones faulty. I can recommend ben (bmh01) top chap and local to you :)
 

·
Premium Member
Joined
·
5,921 Posts
i reckon theyve took the squidgey abs pick up off the old one and damaged it.it only takes a little indent in it to cause a problem.weve had loads of rear delivered for the 225/r26 that are packed the wrong way up and have damaged pick ups
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
sounds like cheap discs with no abs pick up ring on them.were they rears that were replaced?
Yes they were rears,annoying when driving,seeing these lights on my dash,is there anything i can do?they were alot cheaper than original renault parts,spose you get what you pay for.What do you mean by 'pick up ring' ?
As ive said,when turning off engine,it resets itself and often i can do 50 miles before it comes back on,sometimes though only 2.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
Its very strange what happens,sometimes i can do 50 miles with no warning light coming on and sometimes i can do 2 then it comes on but as ive said,it resets itself when turning the engine off.Thanks for your help,would it help at all if i disconnected the battery for a short time?
 
1 - 11 of 11 Posts
Top