Megane Sport Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,560 Posts
Discussion Starter · #1 ·
Well it turns out Renault Blandford are sh*t and never changed a thing on my car (said they had done all coils and one injector!)
Found out after a winge to RUK customer sevices
So it went to Salisbury and they seem to know what they are doing

they changed the plugs (free of charge) as two where buggered
and one injector, but the TFL came on again, so looks like one of the other three has now packed up!

might get a perfect running car one day!
phil
 

·
Registered
Joined
·
5,267 Posts
dont worry phil......mines in aswell having the reving issue sorted. It could be injectors but if it isnt then its a neidel in a haystack job for the dealers.

Amusingly the problem i have on mine isnt detected by clip :p
 

·
Registered
Joined
·
1,560 Posts
Discussion Starter · #3 ·
Crap aint it!

makes me want to chop it in for something else sometimes!
 

·
Registered
Joined
·
1,560 Posts
Discussion Starter · #5 ·
Hope so its driving me nuts, you can hear it misfiring badly!
 

·
Registered
Joined
·
5,267 Posts
Well latest update on mine is that they have run out of fuel on the car to be able to do testing. They called me to ok them putting another £15 into the car.

Other than that they have established that there is a problem but they were doing fuel pressure tests last time i heard anything.
 

·
Registered
Joined
·
1,560 Posts
Discussion Starter · #8 ·
Hmmm, i can see a pattern here!

well at least they seem to be getting a bit more used to the car and how to fix them
phil
 
G

·
Well it aint come on since so i will see how it goes .... It came on 5 times when i was having the car cleaned a few weeks back so that is why i took it back in ...you could see it misfiring really bad ...
 

·
Registered
Joined
·
1,560 Posts
Discussion Starter · #10 ·
does your new injector have a blue colour marking on it? my new one does
phil
 
1 - 10 of 10 Posts
Top