Megane Sport Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter · #1 · (Edited)
Hi,

I've had a quick search for some relevant info but most of the Cabasse results are a few years old and I can't find an exact answer to my question....

My 04 225 came with a replacement Kenwood head unit but this was also in the boot :



In the dash are 'proper' power and speaker connectors which so I suspect someone has run a cable from the boot to the dash to enable the replacement.

I've replaced the Kenwood with a newer Alpinhe unit from my Clio and would like to get the stalk controls working however I'm left with two connectors which, after reading the forum, appears to be the CANBUS connectors :



Is it possible to get the steering controls working with these? The Autoleads PC99 X12 looks like it will plug straight into the long green connector but I'm not so sure about the smaller black one which has one blue wire coming from it...

It would be nice to get my steering wheel control working as per my Clio - which uses a Connects2 box + a couple of cables - and I don't care about the display working either, but the CANBUS stuff does sound like it is (or certainly was) a nightmare to overcome


Thanks for your help :)
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #3 ·
thats for a 6 disc cd auto changer i think
Ahhh, that would make sense as there's a connector on the head unit in my first post that it would plug into. I assumed (maybe wrongly!) that because it was the only cable that I didn't have a home for that it was the one for the steering wheel/stalks.... Sounds like there may be another connector for those then? I don't spose anyone has a piccy of what I'm looking for do they?

Cheers!
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #5 ·
The green plug is the original for the Cabasse head unit, not CANbus. The CAN connector is a yellow mini-ISO. You'll find the other end of the Cabasse lead in the boot by the amp
Cool, cheers for that - Renault didn't make this easy did they :( The Clio was a breeze compared to the Meggy!

So, and apols if I'm stating the obvious, is there (or should there be) a yellow mini iso lurking behind the dash somewhere which I should be able to connect up via a Connects2 or similar box/cable to my head unit?
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #6 ·
...just had another look and there's no sign of the yellow mini iso connector anywhere behind the dash. Is that another connector that lives in the boot thus would require a cable run the length of the car to relocate it to the front?

Cheers
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #8 ·
Nothing like resurrecting your own thread....

I've looked into this again and am even more confused. In the hatch, the plastic compartment contains nothing, only the aerial cable passes through it. I can see no sign of any connectors or owt where I would expect the amp part of the cabasse unit to plug into, so where that terminates I really don't know...

Looking at the cables in the dash they are proper Renault ones - not some after market job that I thought at first. This is confirmed (i think) by them coming out of the ribbed cabled shroud in the driver's footwell - looks way to normal for a 3rd party effort.

Whilst trying to find the CAN connector as per cactubob's last post I came across this cable:



Which comes out of the ribbed connector in the drivers footwell (badly highlighted here)



and was routed back along the trunking along the driver's seat. The connectors were duck taped up so obviously someone has taken them from the dash (the length of the cable is perfect for locating in the dash) and hidden them out of the way. The fact they're coming out of the trunking suggests they've come from 'somewhere' and terminate in the dash. Not sure where that somewhere is though in the absence of any cables/connectors in the hatch...

So, with those relocated in the dash these are the connectors I have to play with...


...one power + one speakers and the flat green one is the one that plugged into the Cabasse unit that was in the dash



Yellow one is the one I'm after for the stalk controls isn't it? Not sure what the blue one is, nor the red one. However all three + the power/speaker connectors that were already in the dash have sockets on the amp part of the Cabasse that should live in the hatch.

I thought the only one that should be there is the flat green one and all the others would be in the hatch plugged into the amp? Maybe someone has re-routed all the cables in the past which would explain why the power & speaker cables are in the dash but it does seem very oem.... Confused.com

Anyway, I have all the connectors in the dash now, the power & speaker ones work fine on the replacement head unit soooooooo is it simply a case of getting a Connects2 box (+ Alpine lead), plugging it into the yellow connector that was duck taped up and everything sparks into life?

Or am I missing a trick somewhere? ;)
 

·
Registered
Joined
·
1 Posts
Sorry to necro your thread but it is by far the most detailed one I can find on the Cabasse unit andd I'm hoping it applies to my 06 coupe.
Were any of the plugs you found for the steering wheel controls?
 
1 - 9 of 9 Posts
Top