Megane Sport Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi folks, new to this. Just bought a07 plate 225 meganesport. Brought it 150 miles up the motorway home, and done another maybe 50 miles afterwards then "check injection" appeared on the dash. Have put 4 brand new genuine coilpacks in and 4 new performance spark plugs in, and still no better. I noticed there is a bolt in the Bank 2 lambda sensor hole, and the lambda sensor looks as if the wires have been cut! Would this affect it and send it into limp mode? Any advice at all would help, cheers
 

· Registered
Joined
·
454 Posts
mine had this issues a while back and it was the earth issue for the injection ecu, took the garage 3 weeks to find out following every single wires in the engine bay until they found this.

since then no more issues
 

· Registered
Joined
·
3 Posts
Ive got a f1 230 r26 and im getting that check injection and goin into limp mode too but mines comes up a throttle body fault ive cleaned it but no joy still doin it ive got a new throttle body coming next week hopefully that solves it any1 get theyre issue sorted and what it turn out to be
 

· Registered
Joined
·
1 Posts
Good day

My 2008 Megane GT also started with the Check Injection. Goes into limp mode can't rev more than 2500. Went through all the steps, Checking the wires, Fuel Pump and alot more. At last got the chance to put on the computer and said "Turbo Charge Control Solenoid Valve". It sits on the pipe coming from the airfilter box to the Turbo. Took mine out cleaned it used some Q20 and tried it again. (Part NO: 8200702990) Problem Solved. Ran the car on the computer and showed it opened and closed again. Problem Fixed.
Hope it will help someone else.
 

· Registered
Joined
·
51 Posts
Get you battery tested as it could be knackered, I have had this on a 175 dci before as well as intermittent alarm going off, cleared fault and kept coming back a week later, changed battery cleared fault all fixed. I.e this can be a voltage problem. Also see some above has put above that they are going to change injectors these will need to be coded to the ecu so not a simple fix also the fault it check injection not injectors, this is just Renault spiel to say these is a fault of which has nothing to do with injectors.
 

· Registered
Joined
·
0 Posts
Good day

My 2008 Megane GT also started with the Check Injection. Goes into limp mode can't rev more than 2500. Went through all the steps, Checking the wires, Fuel Pump and alot more. At last got the chance to put on the computer and said "Turbo Charge Control Solenoid Valve". It sits on the pipe coming from the airfilter box to the Turbo. Took mine out cleaned it used some Q20 and tried it again. (Part NO: 8200702990) Problem Solved. Ran the car on the computer and showed it opened and closed again. Problem Fixed.
Hope it will help someone else.
Thank you mate you are a saviour ...exactly the same problem on my 225 , i was due to drive down to Cornwall from Norfolk and because you took the time and grace to post this problem you really helped us out ...thank you...
 
1 - 12 of 12 Posts
Top