Megane Sport Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,216 Posts
Discussion Starter · #1 ·
At the moment everytime I start my car up when cold, I get the message 'check injectors' and the service light. After its heated up and start again, it doesn't come on! Whats going on?... Anyone else have/had this problem?

Rich
 

·
Registered
Joined
·
1,216 Posts
Discussion Starter · #3 ·
Coil pack? Clip? :? I'll book it in with renault, see what the score is.

Cheers
 

·
Registered
Joined
·
5,267 Posts
The coil is what power your spark plugs.
Clip is the diagnostic computer system they plug into your car.
 

·
Registered
Joined
·
1,216 Posts
Discussion Starter · #5 ·
oook I see. Booked in with renault now, should hopefully get all sorted out under warranty.
 

·
Registered
Joined
·
5,267 Posts
The coils are a regular problem on all the renaultsport vehicles......clio aswell.

Remind the dealer that they are changed in pairs!

I need to book mine in for a new coil.
 

·
Registered
Joined
·
327 Posts
i just got my car back on Friday because the same problem :x :x
They said to be that has a problem with something...I don´t know how to translate but I´m thinking that it´s the part that you just said..
Tell you the truth I leave all the stuffs that I put to my car(Dump valve/Boost controller)...No problem with them.
It went with the warranty..
:) :)

Don´t worry mate it will take a day at most...I think that your dealer service it´s better than the mexican way...

Cheers
 

·
Registered
Joined
·
1,216 Posts
Discussion Starter · #9 ·
Davelee225 said:
dickie, where you booked it in. Not camden ???
No, booked in at Sutton Park in Coventry (Student up here!), is Camden the dealers in Wolverton?
 
1 - 11 of 11 Posts
Top