Megane Sport Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
Car was fine on standard map, got it remapped to stage 1 yesterday and 3 times now iv been booting it it 3rd/4th gears and the revs have climbed but the engine hasnt picked up. I wasnt riding the clutch and car has never been ragged in first gear. There isnt a smell of clutch when this happens either. Most of the time its fine, picks up just right and theres no problems. Just the 3 times it has happend, has got me thinking...

Any idea's on what it could be/how i could test it? Guessing its going to be expensive...

:crying:

Kris
 

·
Premium Member
Joined
·
3,590 Posts
We mapped it and it's running normal stg1 torque.

If it is slipping then it needs replacing or you'll have to go back to standard mapping although if slipping now i cant see it been too long before it slips on the stock map too.
 

·
Registered
Joined
·
2,394 Posts
Was just about to suggest the above, I read a thread before where the pedal was at fault so definately check that could save you a large bill!
 

·
Registered
Joined
·
2,402 Posts
Mine and alot on here was due to flywheel. All parts need to be changed anyway.
Clutch, flywheel and slave really. Then do you risk std parts again or go smf and risk the eml problems that exist?
Worth doing a little reading on this topic before taking the plunge as your looking a 1k + fitted.
 

·
Registered
Joined
·
296 Posts
Is it a given that the flywheel has to be changed with the clutch or can the clutch be changed if the flywheel is inspected (if possable) and confirmed ok?
 

·
Registered
Joined
·
2,402 Posts
Not a must, but many would say to change all 3 parts if your going to the trouble.
I changed to r26r clutch and smf and so far have no issues apart from its a bit more difficult to set off without stalling. Mine went at 33k (flywheel). Clutch was still pretty good on inspection.

Just what you need 2 weeks before Christmas! Good luck.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #16 ·
Deffo not the map causing it and in no way, shape or form did i suggest that is was the map. Its just one of those things. Hasnt done it at all today and has been spot on. Maybe just a blip with the car getting used to stg 1...heres hoping!! :)
 

·
Premium Member
Joined
·
1,218 Posts
Well mine slipped randomly with stage 1 under high torque, then got stage 2 and it slipped under high torque, this was at around 33k - got box out and inspected, allthough clutch was not worn to rivets, it did have heat marks on it from slipping, as did the surface of the flywheel - the standard clutch could deffinatley not handle the stage 2 power (a brand new clutch might - but lets face it probably not for long). The flywheel wasnt completley shot, and movement in it was within tolerance so could of gone again really. but i didnt risk it, got a .r solid flywheel, .r clutch from renault and a new slave and fitted it all. No slipping what so ever, but i do suffer with the fault code and emissions light coming on
 

·
Premium Member
Joined
·
5,759 Posts
What are the signs of bad flywheel out of intresst?
Rattle on idle, it'll slip then be ok for a few days then start slipping again and will get worse over time. If it slips constantly its probably the clutch, intermittently its probably the flywheel. Mine failed at 52k, the clutch had another 52k in it at least not heavily worn the flywheel on the other hand was shot.
 

·
Premium Member
Joined
·
5,759 Posts
Well mine slipped randomly with stage 1 under high torque, then got stage 2 and it slipped under high torque, this was at around 33k - got box out and inspected, allthough clutch was not worn to rivets, it did have heat marks on it from slipping, as did the surface of the flywheel - the standard clutch could deffinatley not handle the stage 2 power (a brand new clutch might - but lets face it probably not for long). The flywheel wasnt completley shot, and movement in it was within tolerance so could of gone again really. but i didnt risk it, got a .r solid flywheel, .r clutch from renault and a new slave and fitted it all. No slipping what so ever, but i do suffer with the fault code and emissions light coming on
I'd been running stage 2 for 12 months before mine started slipping and it was the flywheel not the clutch for me, all replaced with standard parts as other options weren't avaliable at the time. Touch wood 18 months later its still all ok.

Clutch can take stage 2 but I feel it either accellerates flywheel wear, shows up a not brilliant one in the first place or its just plain bad luck.
 
1 - 20 of 25 Posts
Top