Megane Sport Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone,

Does anyone here this clicking sound before? Renault Megane IV clicking when turning

I cannot feel anything from inside the car and actually nor from outside (hub, tie rod, wishbone...). It does not make any sound when its on elevator. I did replace rod ends and sway bar links, tie rods are stiff and feel about right.
Any help would be appreciate.

Best,
Radu
 

·
Registered
Joined
·
2 Posts
Hi everyone,

Does anyone here this clicking sound before? Renault Megane IV clicking when turning

I cannot feel anything from inside the car and actually nor from outside (hub, tie rod, wishbone...). It does not make any sound when its on elevator. I did replace rod ends and sway bar links, tie rods are stiff and feel about right.
Any help would be appreciate.

Best,
Radu
Mine does the same. And apparently it comes from the 4 Control steering system, can't be fixed, needs to be replaced and it costs a ton of money :)
 

·
Registered
Joined
·
1 Posts
Mine does the same. And apparently it comes from the 4 Control steering system, can't be fixed, needs to be replaced and it costs a ton of money :)
Hi everyone,

Does anyone here this clicking sound before? Renault Megane IV clicking when turning

I cannot feel anything from inside the car and actually nor from outside (hub, tie rod, wishbone...). It does not make any sound when its on elevator. I did replace rod ends and sway bar links, tie rods are stiff and feel about right.
Any help would be appreciate.

Best,
Radu
I have the exact same sound when steering, after tons of searching i found out it is the brakepad clip making the sound.
Could be the same for you.

Gr,
Niek
 
1 - 3 of 3 Posts
Top