Megane Sport Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1,560 Posts
Discussion Starter · #1 ·
I have been looking into this, if you look at the picture below you can buy a temp sensor to fit straight into the sump plug. Then install a gauge run the signal from the sensor, supply +12v and a Ground (for the signal and the voltage) and voila!
not messed with the ECU or wiring so easy to move if needed

As far as pressure goes there is a sensor that will tell when the pressure drops too low and illuinate the 'check oil' lamp, but its not sufficient to provide a good enough signal for pressure i think. so you'd need to replace the sensor for a better pressure sensor. but its linked to the ECU(at a guess) so you'd have problems maybe, or tap into the oil gallery and put a seperate one in!(think i'll leave that one for now!)
temp sensor

pressure sensor
 

·
Registered
Joined
·
227 Posts
I am litlte unfamiliar with the pressure sensor set up on the 225. I have fitted pressure guages before to my cars and left the original sensor in.
If the pressure sensor screws into the engine block this can be removed and replaced with a T Piece. This T piece can then house the original sensor and the new sensor for the pressure gauge. This T piece can also house the temp sensor if you do not want to play around with a sump mounting.

Hope this helps,

Uncle
 

·
Registered
Joined
·
1,560 Posts
Discussion Starter · #3 ·
Cool good idea with the T piece, i wanted this thread to get some ideas going
i think personally i will go for the sump plug for the temp as i dont want to void my warranty or risk it, and it looks easy!

i'll have to look to see if i can find the original pressure sensor,but i would be happy with the temp 1st!
phil :D
 
1 - 3 of 3 Posts
Top