Megane Sport Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
hi people
Just wondered if anyone could help me...
my abs and esp light keeps coming up on the dash not all the time,any one know why this would be occuring thanks any advice would be great mark:sweatdrop:
 

·
Premium Member
Joined
·
1,503 Posts
My coils went and came up saying ESP fault, but If running fine shouldn't be That.

Lemonnobby should have a good idea pal.
 

·
Registered
Joined
·
111 Posts
hi people
Just wondered if anyone could help me...
my abs and esp light keeps coming up on the dash not all the time,any one know why this would be occuring thanks any advice would be great mark:sweatdrop:
The front ABS sensors only sit in little clips next to the cv joint behind the wheel bearing and its common for them to fall out if they are all fitted you will need to get it plugged in to a scanner for some live data to see which wheel isn't giving a signal to the ABS ecu. Worst case is the ABS ecu itself, but I've never come across a faulty one on a Megane. Hope this helps message me if you need any help
 

·
Meganesport Area Rep - South West
Joined
·
6,404 Posts
Front and rear Abs sensors can play up. Have you had any work done on the brakes recently ?
Get it checked on a scanner
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #12 ·
no mate nowt done, doing front brakes at weekend disc and pads. can they turn the fault code off or will i need a new sensor? thanks mark
 

·
Meganesport Area Rep - South West
Joined
·
6,404 Posts
Depends on.the fault but I suspect it will need to be fixed rather than just erased
 
1 - 13 of 13 Posts
Top