Megane Sport Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7,527 Posts
Discussion Starter · #1 ·
Hey guys,

Just wanted to check out something, my cars now 3.5 years old and clocking some mileage after moving further away from work. Since the cold weather the car seems to be running rather cold, see the pics below. The temp gauge runs like that in normal driving. It used to run dead centre and the scangauge shows 70-75 degrees where as before it used to run at 80-85 normal driving. Also noticed higher fuel consumption, only hitting around 270 to a tank.

Temperature Gauge


Scan Gauge*


Any thoughts? I had considered thermostat or a temp sensor.
 

·
Premium Member
Joined
·
3,292 Posts
Do you hit the cold limiter all the time. If you do its probs the thermostat because thathats where it sat on mine when it went
 

·
Registered
Joined
·
7,527 Posts
Discussion Starter · #5 ·
I noticed that a few days ago, drove for almost 30 mins then pulled away quite quickly and it felt like it died in second and wouldn't rev for a few seconds, thought id hit the limiter. Where is the thermostat?
 

·
Premium Member
Joined
·
3,292 Posts
Right hand side of the block. Just under the unit that is connected to that hose with the plastic clip iirc think its 2 or 3 bolts but its getting to it whats the fun part
 

·
Premium Member
Joined
·
4,798 Posts
Time for a new thermostat mate.

I think a renault part is about £19 and only takes about 15 minutes to change.
 

·
Registered
Joined
·
180 Posts
Exact same thing happened on my car tonight. How do you know if it's the sensor or thermostat?

Anyone got any pics of where it is located?
 

·
Registered
Joined
·
7,527 Posts
Discussion Starter · #10 ·
I'll take some, which fluid does the R26 take? I'll flush the system while I'm there.

Thank you for your responses :)
 

·
Premium Member
Joined
·
3,292 Posts
Exact same thing happened on my car tonight. How do you know if it's the sensor or thermostat?

Anyone got any pics of where it is located?
If its the sensor the guage wouldnt read correctly if its the thermostat the car wont go past the cold limiter even when warmed up.
 

·
Premium Member
Joined
·
404 Posts
i started having the same issue couple of weeks back when the COLD weather started as low as (15 C ) and i plugged the data logging and it showed a fluctuation of 20 C so the thermostat is closing and opening few times befor it sets this just two weeks ago. will visit the dealer next week to check it up.
 
1 - 13 of 13 Posts
Top