Megane Sport Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,488 Posts
Discussion Starter · #1 ·
one

my rear upper brake light must have a let a little water in, which froze, expanded and poped the light out, the seal is buggerd, do i need a full new light or do renault do a new seal? or is it a silicon bodge job?

two

ive used by car for daily commute to a course each day this week, on 3 occosions while stuck in 30min of traffic in balfast the check injection light/warning has come on, no missfires byt the car dose go to limp mode, done a search and most answers seem to be injectors, ive got new ktec bigger injectors, any other options it could be? always seems to be when sat still or creeping forward in traffic for a long time, also every day as been terential rain, or wet with constant drizzle or very damp fog but freezing cold, could it just be the cold and damp?

once the course is over and dont need the car for a commute ill get it on clip, jsy after any advice if anyone has had the same?

use it most nites for a fast blast on a 20min trip to lisburn and back and its fine, only ever in traffic?

thanks again

ps, i did search this already, just cant belive its my injectors.
 

·
Meganesport Area Rep - South West
Joined
·
6,404 Posts
i wonder if it more of a pump supply issue? or just a bad sensor

i would just get a new light mate
 

·
Premium Member
Joined
·
5,759 Posts
The usual injector misfire doesn't put the car into limp mode, although with ktec products who knows. Get the codes read (preferably with clip) before doing anything else.
 
1 - 4 of 4 Posts
Top